<!DOCTYPE html>
<html lang="en-US">
<head >
<meta charset="UTF-8" />
		<meta name="robots" content="noodp,noydir" />
		<meta name="viewport" content="width=device-width, initial-scale=1" />
<title>Mecklenburg County announces closings for Independence Day</title>
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Matthews - Mint Hill Weekly &raquo; Feed" href="https://www.matthewsminthillweekly.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Matthews - Mint Hill Weekly &raquo; Comments Feed" href="https://www.matthewsminthillweekly.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Matthews - Mint Hill Weekly &raquo; Mecklenburg County announces closings for Independence Day Comments Feed" href="https://www.matthewsminthillweekly.com/news/2020/06/mecklenburg-county-announces-closings-for-independence-day/feed/" />
<link rel="canonical" href="https://www.matthewsminthillweekly.com/news/2020/06/mecklenburg-county-announces-closings-for-independence-day/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.matthewsminthillweekly.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.8"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='metro-pro-theme-css'  href='https://www.matthewsminthillweekly.com/wp-content/themes/metro-pro/style.css?ver=2.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-add-custom-css-css'  href='https://www.matthewsminthillweekly.com?display_custom_css=css&#038;ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://www.matthewsminthillweekly.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://www.matthewsminthillweekly.com/wp-content/plugins/jetpack/css/jetpack.css?ver=6.8.1' type='text/css' media='all' />
<script type='text/javascript' src='https://www.matthewsminthillweekly.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://www.matthewsminthillweekly.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.matthewsminthillweekly.com/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?ver=20150408'></script>
<link rel='https://api.w.org/' href='https://www.matthewsminthillweekly.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.matthewsminthillweekly.com/xmlrpc.php?rsd" />
<link rel="alternate" type="application/json+oembed" href="https://www.matthewsminthillweekly.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.matthewsminthillweekly.com%2Fnews%2F2020%2F06%2Fmecklenburg-county-announces-closings-for-independence-day%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.matthewsminthillweekly.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.matthewsminthillweekly.com%2Fnews%2F2020%2F06%2Fmecklenburg-county-announces-closings-for-independence-day%2F&#038;format=xml" />
<style type="text/css">div.simplesocial,a.simplesocial{float:left;display:block}a.simplesocial{margin-right:5px;width:16px;height:16px}a.simplesocial:hover{margin-top:-2px}</style>
<script language="javascript">function simplesocial(t,w,h){
window.open(t.href, 'simplesocial', 'scrollbars=1,menubar=0,width='+w+',height='+h+',resizable=1,toolbar=0,location=0,status=0,left='+(screen.width-w)/2+',top='+(screen.height-h)/3);
return false;}</script>

<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<link rel='dns-prefetch' href='//i0.wp.com'/>
<link rel='dns-prefetch' href='//i1.wp.com'/>
<link rel='dns-prefetch' href='//i2.wp.com'/>
<style type='text/css'>img#wpstats{display:none}</style><link rel="icon" href="https://www.matthewsminthillweekly.com/wp-content/themes/metro-pro/images/favicon.ico" />
<link rel="stylesheet" type="text/css" href="https://www.matthewsminthillweekly.com/wp-content/themes/metro-pro/style_customizd.css"><style>body { background-color: #4c5a18; }</style>
			<style type="text/css">
				html:not( .jetpack-lazy-images-js-enabled ) .jetpack-lazy-image {
					display: none;
				}
			</style>
			<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
		
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Mecklenburg County announces closings for Independence Day" />
<meta property="og:url" content="https://www.matthewsminthillweekly.com/news/2020/06/mecklenburg-county-announces-closings-for-independence-day/" />
<meta property="og:description" content="CHARLOTTE – County offices and services will be closed Friday, July 3, for the Independence Day holiday. This includes all units of the Department of Social Services, the Tax Office, the Elections …" />
<meta property="article:published_time" content="2020-06-28T15:11:13+00:00" />
<meta property="article:modified_time" content="2020-06-28T15:11:13+00:00" />
<meta property="og:site_name" content="Matthews - Mint Hill Weekly" />
<meta property="og:image" content="https://s0.wp.com/i/blank.jpg" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:text:title" content="Mecklenburg County announces closings for Independence Day" />
<meta name="twitter:card" content="summary" />

<!-- End Jetpack Open Graph Tags -->
</head>
<body class="post-template-default single single-post postid-37554 single-format-standard custom-background custom-header header-full-width content-sidebar metro-pro-blue" itemscope itemtype="https://schema.org/WebPage"><div class="site-container"><header class="site-header" itemscope itemtype="https://schema.org/WPHeader"><div class="wrap"></div></header><nav class="nav-primary" aria-label="Main" itemscope itemtype="https://schema.org/SiteNavigationElement"><div class="wrap"><ul id="menu-header" class="menu genesis-nav-menu menu-primary"><li id="menu-item-27513" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-27513"><a href="https://www.matthewsminthillweekly.com" itemprop="url"><span itemprop="name">Home</span></a></li>
<li id="menu-item-27558" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-27558"><a href="https://www.matthewsminthillweekly.com/category/news/" itemprop="url"><span itemprop="name">News</span></a></li>
<li id="menu-item-27515" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27515"><a href="https://www.matthewsminthillweekly.com/category/education/" itemprop="url"><span itemprop="name">Education</span></a></li>
<li id="menu-item-27514" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27514"><a href="https://www.matthewsminthillweekly.com/category/sports/" itemprop="url"><span itemprop="name">Sports</span></a></li>
<li id="menu-item-27516" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27516"><a href="https://www.matthewsminthillweekly.com/category/arts-entertainment/" itemprop="url"><span itemprop="name">Arts &#038; Entertainment</span></a></li>
<li id="menu-item-27519" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-27519"><a href="http://carolinaweekly.com" itemprop="url"><span itemprop="name">CMG</span></a>
<ul class="sub-menu">
	<li id="menu-item-27520" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-27520"><a href="http://thecharlotteweekly.com/" itemprop="url"><span itemprop="name">South Charlotte</span></a></li>
	<li id="menu-item-27521" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-27521"><a href="http://unioncountyweekly.com" itemprop="url"><span itemprop="name">Union County</span></a></li>
</ul>
</li>
<li id="menu-item-27522" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-27522"><a href="http://#" itemprop="url"><span itemprop="name">Contact Us</span></a>
<ul class="sub-menu">
	<li id="menu-item-31651" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-31651"><a href="https://www.matthewsminthillweekly.com/contact-us/" itemprop="url"><span itemprop="name">Contact Us</span></a></li>
	<li id="menu-item-31650" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-31650"><a href="https://www.matthewsminthillweekly.com/advertise/" itemprop="url"><span itemprop="name">Advertise</span></a></li>
</ul>
</li>
<li id="menu-item-33835" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33835"><a href="http://cmgweekly.com/jobs/" itemprop="url"><span itemprop="name">Jobs</span></a></li>
<li id="menu-item-37193" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37193"><a href="https://www.matthewsminthillweekly.com/best-of-the-weekly/" itemprop="url"><span itemprop="name">Best of the Weekly</span></a></li>
</ul></div></nav><div class="site-inner"><div class="wallpaperdiv">

</a></div><div class="content-sidebar-wrap"><main class="content"><div class="breadcrumb" itemscope itemtype="https://schema.org/BreadcrumbList">You are here: <span class="breadcrumb-link-wrap" itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem"><a class="breadcrumb-link" href="https://www.matthewsminthillweekly.com/" itemprop="item"><span class="breadcrumb-link-text-wrap" itemprop="name">Home</span></a><meta itemprop="position" content="1"></span> <span aria-label="breadcrumb separator">/</span> <span class="breadcrumb-link-wrap" itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem"><a class="breadcrumb-link" href="https://www.matthewsminthillweekly.com/category/news/" itemprop="item"><span class="breadcrumb-link-text-wrap" itemprop="name">News</span></a><meta itemprop="position" content="2"></span> <span aria-label="breadcrumb separator">/</span> Mecklenburg County announces closings for Independence Day</div><article class="post-37554 post type-post status-publish format-standard category-news entry" itemscope itemtype="https://schema.org/CreativeWork"><header class="entry-header"><h1 class="entry-title" itemprop="headline">Mecklenburg County announces closings for Independence Day</h1>
<p class="entry-meta"><time class="entry-time" itemprop="datePublished" datetime="2020-06-28T11:11:13+00:00">June 28, 2020</time> by <span class="entry-author" itemprop="author" itemscope itemtype="https://schema.org/Person"><a href="https://www.matthewsminthillweekly.com/author/admin/" class="entry-author-link" itemprop="url" rel="author"><span class="entry-author-name" itemprop="name">admin</span></a></span> <span class="entry-comments-link"><a href="https://www.matthewsminthillweekly.com/news/2020/06/mecklenburg-county-announces-closings-for-independence-day/#respond">Leave a Comment</a></span> </p></header><div class="entry-content" itemprop="text"><p><span style="font-size: small;">CHARLOTTE – County offices and services will be closed Friday, July 3, for the Independence Day holiday.</span></p>
<p><span style="font-size: small;">This includes all units of the Department of Social Services, the Tax Office, the Elections Office, the Register of Deeds Office, and the Land Use and Environmental Services Agency offices.</span></p>
<p><span style="font-size: small;">The Department of Social Services hotlines operate 24 hours a day, seven days a week to receive reports of suspected abuse or neglect. Call 704-336-2273 To report abuse of seniors or the disabled. Call 980-314-3577 to report abuse, neglect or human trafficking of children.</span></p>
<p><span style="font-size: small;">The Health Department will be closed July 3.</span></p>
<p><span style="font-size: small;">The Main Library and all library branches will be closed July 3.</span></p>
<p><span style="font-size: small;">All County Solid Waste facilities and full-service centers will be closed July 3 and 4. City of Charlotte Solid Waste Services will provide collection services July 3.</span></p>
<p><span style="font-size: small;">Parks, Nature Preserves and Greenways will remain open.</span></p>
<p><span style="font-size: small;">The Mecklenburg County Aquatic Center will be open July 3. Summer programs will be operating at Mallard Creek, Bette Rae Thomas, Albemarle Road, Methodist Home and Southview Recreation Centers.</span></p>
<p><span style="font-size: small;">All other recreation centers, senior centers, nature centers, indoor rental facilities and aquatic facilities remain closed due to COVID-19.</span></p>
<p><span style="font-size: small;">CharMeck 311 will close July 3 in observance of the Independence Day holiday. Services will return to COVID-19 operating hours July 6. Outside regular business hours, CharMeck 311 callers can report water, sewer, storm water and animal issues via an automated service that dispatches assistance. Residents can also submit service requests online 24 hours a day or access dozens of city services by downloading the CLT+ mobile app. Call 911 for any emergencies.</span></p>
<div><div style="padding-top:10px;margin-bottom:10px;font-size:10pt;font-family:arial;font-weight:bold;">Did you like this? Share it:</div><div class=simplesocial><a href="http://twitter.com/share" data-url="https://www.matthewsminthillweekly.com/news/2020/06/mecklenburg-county-announces-closings-for-independence-day/" data-text="Mecklenburg+County+announces+closings+for+Independence+Day" class="twitter-share-button" data-count="horizontal">Tweet</a><script type="text/javascript" src="https://platform.twitter.com/widgets.js"></script></div><div class=simplesocial><iframe src="https://www.facebook.com/plugins/like.php?href=https%3A%2F%2Fwww.matthewsminthillweekly.com%2Fnews%2F2020%2F06%2Fmecklenburg-county-announces-closings-for-independence-day%2F&layout=standard&show_faces=false&width=450&action=like&colorscheme=light&height=35" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:450px; height:25px;" allowTransparency="true"></iframe></div><div style="clear:both"></div><a class=simplesocial onclick="return simplesocial(this,500,400)" title="Share on Facebook" style="background:url(https://www.matthewsminthillweekly.com/wp-content/plugins/simple-social-sharing-widgets-icons/icons_16/facebook.png)" href="https://www.facebook.com/share.php?u=https%3A%2F%2Fwww.matthewsminthillweekly.com%2Fnews%2F2020%2F06%2Fmecklenburg-county-announces-closings-for-independence-day%2F&t=Mecklenburg+County+announces+closings+for+Independence+Day"></a><a class=simplesocial onclick="return simplesocial(this,812,420)" title="Share on Twitter" style="background:url(https://www.matthewsminthillweekly.com/wp-content/plugins/simple-social-sharing-widgets-icons/icons_16/twitter.png)" href="http://twitter.com/home?status=https%3A%2F%2Fwww.matthewsminthillweekly.com%2Fnews%2F2020%2F06%2Fmecklenburg-county-announces-closings-for-independence-day%2F"></a><a class=simplesocial onclick="return simplesocial(this,435,500)" title="Email a Friend" style="background:url(https://www.matthewsminthillweekly.com/wp-content/plugins/simple-social-sharing-widgets-icons/icons_16/email.png)" href="http://www.freetellafriend.com/tell/?heading=Share+This+Article&bg=1&option=email&url=https%3A%2F%2Fwww.matthewsminthillweekly.com%2Fnews%2F2020%2F06%2Fmecklenburg-county-announces-closings-for-independence-day%2F"></a><a class=simplesocial onclick="return simplesocial(this,750,500)" title="Share on Blogger" style="background:url(https://www.matthewsminthillweekly.com/wp-content/plugins/simple-social-sharing-widgets-icons/icons_16/blogger.png)" href="http://www.blogger.com/blog_this.pyra?t&u=https%3A%2F%2Fwww.matthewsminthillweekly.com%2Fnews%2F2020%2F06%2Fmecklenburg-county-announces-closings-for-independence-day%2F&n=Mecklenburg+County+announces+closings+for+Independence+Day&pli=1"></a><a class=simplesocial onclick="return simplesocial(this,890,550)" title="Share on Delicious" style="background:url(https://www.matthewsminthillweekly.com/wp-content/plugins/simple-social-sharing-widgets-icons/icons_16/delicious.png)" href="http://del.icio.us/post?url=https%3A%2F%2Fwww.matthewsminthillweekly.com%2Fnews%2F2020%2F06%2Fmecklenburg-county-announces-closings-for-independence-day%2F&title=Mecklenburg+County+announces+closings+for+Independence+Day"></a><a class=simplesocial onclick="return simplesocial(this,812,420)" title="Share on Digg" style="background:url(https://www.matthewsminthillweekly.com/wp-content/plugins/simple-social-sharing-widgets-icons/icons_16/digg.png)" href="http://digg.com/submit?url=https%3A%2F%2Fwww.matthewsminthillweekly.com%2Fnews%2F2020%2F06%2Fmecklenburg-county-announces-closings-for-independence-day%2F&title=Mecklenburg+County+announces+closings+for+Independence+Day"></a><a class=simplesocial onclick="return simplesocial(this,750,500)" title="Share on Google" style="background:url(https://www.matthewsminthillweekly.com/wp-content/plugins/simple-social-sharing-widgets-icons/icons_16/google.png)" href="https://www.google.com/bookmarks/mark?op=add&bkmk=https%3A%2F%2Fwww.matthewsminthillweekly.com%2Fnews%2F2020%2F06%2Fmecklenburg-county-announces-closings-for-independence-day%2F&title=Mecklenburg+County+announces+closings+for+Independence+Day"></a><a class=simplesocial onclick="return simplesocial(this,812,420)" title="Share on Myspace" style="background:url(https://www.matthewsminthillweekly.com/wp-content/plugins/simple-social-sharing-widgets-icons/icons_16/myspace.png)" href="http://www.myspace.com/Modules/PostTo/Pages/?u=https%3A%2F%2Fwww.matthewsminthillweekly.com%2Fnews%2F2020%2F06%2Fmecklenburg-county-announces-closings-for-independence-day%2F&t=Mecklenburg+County+announces+closings+for+Independence+Day&c=https%3A%2F%2Fwww.matthewsminthillweekly.com%2Fnews%2F2020%2F06%2Fmecklenburg-county-announces-closings-for-independence-day%2F"></a><a class=simplesocial onclick="return simplesocial(this,750,500)" title="Share on StumbleUpon" style="background:url(https://www.matthewsminthillweekly.com/wp-content/plugins/simple-social-sharing-widgets-icons/icons_16/stumbleupon.png)" href="http://www.stumbleupon.com/submit?url=https%3A%2F%2Fwww.matthewsminthillweekly.com%2Fnews%2F2020%2F06%2Fmecklenburg-county-announces-closings-for-independence-day%2F&title=Mecklenburg+County+announces+closings+for+Independence+Day"></a><a class=simplesocial onclick="return simplesocial(this,900,550)" title="Share on Yahoo" style="background:url(https://www.matthewsminthillweekly.com/wp-content/plugins/simple-social-sharing-widgets-icons/icons_16/yahoo.png)" href="http://buzz.yahoo.com/buzz?targetUrl=https%3A%2F%2Fwww.matthewsminthillweekly.com%2Fnews%2F2020%2F06%2Fmecklenburg-county-announces-closings-for-independence-day%2F&headline=Mecklenburg+County+announces+closings+for+Independence+Day"></a><a class=simplesocial onclick="return simplesocial(this,700,500)" title="Share on Reddit" style="background:url(https://www.matthewsminthillweekly.com/wp-content/plugins/simple-social-sharing-widgets-icons/icons_16/reddit.png)" href="http://reddit.com/submit?url=https%3A%2F%2Fwww.matthewsminthillweekly.com%2Fnews%2F2020%2F06%2Fmecklenburg-county-announces-closings-for-independence-day%2F&title=Mecklenburg+County+announces+closings+for+Independence+Day"></a><a class=simplesocial onclick="return simplesocial(this,812,500)" title="Share on Technorati" style="background:url(https://www.matthewsminthillweekly.com/wp-content/plugins/simple-social-sharing-widgets-icons/icons_16/technorati.png)" href="http://technorati.com/faves?sub=favthis&add=https%3A%2F%2Fwww.matthewsminthillweekly.com%2Fnews%2F2020%2F06%2Fmecklenburg-county-announces-closings-for-independence-day%2F"></a><a class=simplesocial title="RSS Feed" style="background:url(https://www.matthewsminthillweekly.com/wp-content/plugins/simple-social-sharing-widgets-icons/icons_16/rss.png)" href="https://www.matthewsminthillweekly.com/?feed=rss2"></a></div><div style="clear:both;margin-bottom:20px"></div><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-37554" class="share-twitter sd-button share-icon no-text" href="https://www.matthewsminthillweekly.com/news/2020/06/mecklenburg-county-announces-closings-for-independence-day/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-37554" class="share-facebook sd-button share-icon no-text" href="https://www.matthewsminthillweekly.com/news/2020/06/mecklenburg-county-announces-closings-for-independence-day/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-google-plus-1"><a rel="nofollow noopener noreferrer" data-shared="sharing-google-37554" class="share-google-plus-1 sd-button share-icon no-text" href="https://www.matthewsminthillweekly.com/news/2020/06/mecklenburg-county-announces-closings-for-independence-day/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span></span><span class="sharing-screen-reader-text">Click to share on Google+ (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div></div><footer class="entry-footer"><p class="entry-meta"><span class="entry-categories">Filed Under: <a href="https://www.matthewsminthillweekly.com/category/news/" rel="category tag">News</a></span> </p></footer></article>	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/news/2020/06/mecklenburg-county-announces-closings-for-independence-day/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://www.matthewsminthillweekly.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
				<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p>
<p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='37554' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p>
<!-- Anti-spam plugin v.5.5 wordpress.org/plugins/anti-spam/ -->
		<p class="antispam-group antispam-group-q" style="clear: both;">
			<label>Current ye@r <span class="required">*</span></label>
			<input type="hidden" name="antspm-a" class="antispam-control antispam-control-a" value="2020" />
			<input type="text" name="antspm-q" class="antispam-control antispam-control-q" value="5.5" autocomplete="off" />
		</p>
		<p class="antispam-group antispam-group-e" style="display: none;">
			<label>Leave this field empty</label>
			<input type="text" name="antspm-e-email-url-website" class="antispam-control antispam-control-e" value="" autocomplete="off" />
		</p>
			</form>
			</div><!-- #respond -->
	</main><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar" itemscope itemtype="https://schema.org/WPSideBar"><section id="search-3" class="widget widget_search"><div class="widget-wrap"><h4 class="widget-title widgettitle">Search this site</h4>
<form class="search-form" itemprop="potentialAction" itemscope itemtype="https://schema.org/SearchAction" method="get" action="https://www.matthewsminthillweekly.com/" role="search"><input class="search-form-input" type="search" itemprop="query-input" name="s" id="searchform-1" placeholder="Search"><input class="search-form-submit" type="submit" value="Search"><meta itemprop="target" content="https://www.matthewsminthillweekly.com/?s={s}"></form></div></section>
<section id="media_image-8" class="widget widget_media_image"><div class="widget-wrap"><h4 class="widget-title widgettitle">Omni Elite</h4>
<a href="https://omnieliteathletix.net/"><img width="1250" height="1250" src="https://i0.wp.com/www.matthewsminthillweekly.com/wp-content/uploads/2020/06/OmniElite-Camp-Web.jpg?fit=1250%2C1250&amp;ssl=1" class="image wp-image-37501  attachment-full size-full jetpack-lazy-image" alt="" style="max-width: 100%; height: auto;" data-attachment-id="37501" data-permalink="https://www.matthewsminthillweekly.com/omnielite-camp-web/" data-orig-file="https://i0.wp.com/www.matthewsminthillweekly.com/wp-content/uploads/2020/06/OmniElite-Camp-Web.jpg?fit=1250%2C1250&amp;ssl=1" data-orig-size="1250,1250" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="OmniElite-Camp-Web" data-image-description="&lt;p&gt;ad&lt;/p&gt;
" data-medium-file="https://i0.wp.com/www.matthewsminthillweekly.com/wp-content/uploads/2020/06/OmniElite-Camp-Web.jpg?fit=300%2C300&amp;ssl=1" data-large-file="https://i0.wp.com/www.matthewsminthillweekly.com/wp-content/uploads/2020/06/OmniElite-Camp-Web.jpg?fit=1024%2C1024&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/www.matthewsminthillweekly.com/wp-content/uploads/2020/06/OmniElite-Camp-Web.jpg?w=1250&amp;ssl=1 1250w, https://i0.wp.com/www.matthewsminthillweekly.com/wp-content/uploads/2020/06/OmniElite-Camp-Web.jpg?resize=150%2C150&amp;ssl=1 150w, https://i0.wp.com/www.matthewsminthillweekly.com/wp-content/uploads/2020/06/OmniElite-Camp-Web.jpg?resize=300%2C300&amp;ssl=1 300w, https://i0.wp.com/www.matthewsminthillweekly.com/wp-content/uploads/2020/06/OmniElite-Camp-Web.jpg?resize=768%2C768&amp;ssl=1 768w, https://i0.wp.com/www.matthewsminthillweekly.com/wp-content/uploads/2020/06/OmniElite-Camp-Web.jpg?resize=1024%2C1024&amp;ssl=1 1024w" data-lazy-sizes="(max-width: 1250px) 100vw, 1250px" data-lazy-src="https://i0.wp.com/www.matthewsminthillweekly.com/wp-content/uploads/2020/06/OmniElite-Camp-Web.jpg?fit=1250%2C1250&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a></div></section>
<section id="media_image-10" class="widget widget_media_image"><div class="widget-wrap"><h4 class="widget-title widgettitle">Klaar</h4>
<a href="https://www.cklaar.com/"><img width="1250" height="1250" src="https://i2.wp.com/www.matthewsminthillweekly.com/wp-content/uploads/2020/06/Klaar-Web.jpg?fit=1250%2C1250&amp;ssl=1" class="image wp-image-37502  attachment-full size-full jetpack-lazy-image" alt="" style="max-width: 100%; height: auto;" data-attachment-id="37502" data-permalink="https://www.matthewsminthillweekly.com/klaar-web/" data-orig-file="https://i2.wp.com/www.matthewsminthillweekly.com/wp-content/uploads/2020/06/Klaar-Web.jpg?fit=1250%2C1250&amp;ssl=1" data-orig-size="1250,1250" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Klaar-Web" data-image-description="&lt;p&gt;ad&lt;/p&gt;
" data-medium-file="https://i2.wp.com/www.matthewsminthillweekly.com/wp-content/uploads/2020/06/Klaar-Web.jpg?fit=300%2C300&amp;ssl=1" data-large-file="https://i2.wp.com/www.matthewsminthillweekly.com/wp-content/uploads/2020/06/Klaar-Web.jpg?fit=1024%2C1024&amp;ssl=1" data-lazy-srcset="https://i2.wp.com/www.matthewsminthillweekly.com/wp-content/uploads/2020/06/Klaar-Web.jpg?w=1250&amp;ssl=1 1250w, https://i2.wp.com/www.matthewsminthillweekly.com/wp-content/uploads/2020/06/Klaar-Web.jpg?resize=150%2C150&amp;ssl=1 150w, https://i2.wp.com/www.matthewsminthillweekly.com/wp-content/uploads/2020/06/Klaar-Web.jpg?resize=300%2C300&amp;ssl=1 300w, https://i2.wp.com/www.matthewsminthillweekly.com/wp-content/uploads/2020/06/Klaar-Web.jpg?resize=768%2C768&amp;ssl=1 768w, https://i2.wp.com/www.matthewsminthillweekly.com/wp-content/uploads/2020/06/Klaar-Web.jpg?resize=1024%2C1024&amp;ssl=1 1024w" data-lazy-sizes="(max-width: 1250px) 100vw, 1250px" data-lazy-src="https://i2.wp.com/www.matthewsminthillweekly.com/wp-content/uploads/2020/06/Klaar-Web.jpg?fit=1250%2C1250&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a></div></section>
<section id="media_image-11" class="widget widget_media_image"><div class="widget-wrap"><h4 class="widget-title widgettitle">CPCC</h4>
<a href="https://www.cpcc.edu/"><img width="1250" height="1250" src="https://i0.wp.com/www.matthewsminthillweekly.com/wp-content/uploads/2020/06/CPCC-0619-Web.jpg?fit=1250%2C1250&amp;ssl=1" class="image wp-image-37503  attachment-full size-full jetpack-lazy-image" alt="" style="max-width: 100%; height: auto;" data-attachment-id="37503" data-permalink="https://www.matthewsminthillweekly.com/cpcc-0619-web/" data-orig-file="https://i0.wp.com/www.matthewsminthillweekly.com/wp-content/uploads/2020/06/CPCC-0619-Web.jpg?fit=1250%2C1250&amp;ssl=1" data-orig-size="1250,1250" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="CPCC-0619-Web" data-image-description="&lt;p&gt;ad&lt;/p&gt;
" data-medium-file="https://i0.wp.com/www.matthewsminthillweekly.com/wp-content/uploads/2020/06/CPCC-0619-Web.jpg?fit=300%2C300&amp;ssl=1" data-large-file="https://i0.wp.com/www.matthewsminthillweekly.com/wp-content/uploads/2020/06/CPCC-0619-Web.jpg?fit=1024%2C1024&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/www.matthewsminthillweekly.com/wp-content/uploads/2020/06/CPCC-0619-Web.jpg?w=1250&amp;ssl=1 1250w, https://i0.wp.com/www.matthewsminthillweekly.com/wp-content/uploads/2020/06/CPCC-0619-Web.jpg?resize=150%2C150&amp;ssl=1 150w, https://i0.wp.com/www.matthewsminthillweekly.com/wp-content/uploads/2020/06/CPCC-0619-Web.jpg?resize=300%2C300&amp;ssl=1 300w, https://i0.wp.com/www.matthewsminthillweekly.com/wp-content/uploads/2020/06/CPCC-0619-Web.jpg?resize=768%2C768&amp;ssl=1 768w, https://i0.wp.com/www.matthewsminthillweekly.com/wp-content/uploads/2020/06/CPCC-0619-Web.jpg?resize=1024%2C1024&amp;ssl=1 1024w" data-lazy-sizes="(max-width: 1250px) 100vw, 1250px" data-lazy-src="https://i0.wp.com/www.matthewsminthillweekly.com/wp-content/uploads/2020/06/CPCC-0619-Web.jpg?fit=1250%2C1250&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a></div></section>
<section id="media_image-13" class="widget widget_media_image"><div class="widget-wrap"><h4 class="widget-title widgettitle">Mara</h4>
<a href="https://www.marasports.org/"><img width="300" height="300" src="https://i2.wp.com/www.matthewsminthillweekly.com/wp-content/uploads/2020/06/Mara-0619-Web-1.jpg?fit=300%2C300&amp;ssl=1" class="image wp-image-37506  attachment-medium size-medium jetpack-lazy-image" alt="" style="max-width: 100%; height: auto;" data-attachment-id="37506" data-permalink="https://www.matthewsminthillweekly.com/mara-0619-web-2/" data-orig-file="https://i2.wp.com/www.matthewsminthillweekly.com/wp-content/uploads/2020/06/Mara-0619-Web-1.jpg?fit=1250%2C1250&amp;ssl=1" data-orig-size="1250,1250" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Mara-0619-Web" data-image-description="&lt;p&gt;ad&lt;/p&gt;
" data-medium-file="https://i2.wp.com/www.matthewsminthillweekly.com/wp-content/uploads/2020/06/Mara-0619-Web-1.jpg?fit=300%2C300&amp;ssl=1" data-large-file="https://i2.wp.com/www.matthewsminthillweekly.com/wp-content/uploads/2020/06/Mara-0619-Web-1.jpg?fit=1024%2C1024&amp;ssl=1" data-lazy-srcset="https://i2.wp.com/www.matthewsminthillweekly.com/wp-content/uploads/2020/06/Mara-0619-Web-1.jpg?w=1250&amp;ssl=1 1250w, https://i2.wp.com/www.matthewsminthillweekly.com/wp-content/uploads/2020/06/Mara-0619-Web-1.jpg?resize=150%2C150&amp;ssl=1 150w, https://i2.wp.com/www.matthewsminthillweekly.com/wp-content/uploads/2020/06/Mara-0619-Web-1.jpg?resize=300%2C300&amp;ssl=1 300w, https://i2.wp.com/www.matthewsminthillweekly.com/wp-content/uploads/2020/06/Mara-0619-Web-1.jpg?resize=768%2C768&amp;ssl=1 768w, https://i2.wp.com/www.matthewsminthillweekly.com/wp-content/uploads/2020/06/Mara-0619-Web-1.jpg?resize=1024%2C1024&amp;ssl=1 1024w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" data-lazy-src="https://i2.wp.com/www.matthewsminthillweekly.com/wp-content/uploads/2020/06/Mara-0619-Web-1.jpg?fit=300%2C300&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a></div></section>
</aside></div></div></div><footer class="site-footer" itemscope itemtype="https://schema.org/WPFooter"><div class="wrap">McElvy Media &#x000A9;&nbsp;2020 </div></footer>	<div style="display:none">
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/www.matthewsminthillweekly.com\/news\/2020\/06\/mecklenburg-county-announces-closings-for-independence-day\/":37554};
	</script>
				<script type='text/javascript' src='https://www.matthewsminthillweekly.com/wp-content/plugins/jetpack/_inc/build/photon/photon.min.js?ver=20130122'></script>
<script type='text/javascript' src='https://www.matthewsminthillweekly.com/wp-content/plugins/anti-spam/js/anti-spam-5.5.js'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=202026'></script>
<script type='text/javascript' src='https://www.matthewsminthillweekly.com/wp-includes/js/comment-reply.min.js?ver=4.9.8'></script>
<script type='text/javascript' src='https://www.matthewsminthillweekly.com/wp-content/plugins/jetpack/_inc/build/lazy-images/js/lazy-images.min.js?ver=6.8.1'></script>
<script type='text/javascript' src='https://www.matthewsminthillweekly.com/wp-includes/js/wp-embed.min.js?ver=4.9.8'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.matthewsminthillweekly.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=6.8.1'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-google-plus-1', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
</script>
<script type='text/javascript' src='https://stats.wp.com/e-202026.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:6.8.1',blog:'104050563',post:'37554',tz:'-4',srv:'www.matthewsminthillweekly.com'} ]);
	_stq.push([ 'clickTrackerInit', '104050563', '37554' ]);
</script>
</body></html>
